#1 Probleme seit Update/Export von milano 29.05.2009 13:52

Hallo,

ich habe kürzlich das neueste Update durchgeführt und kurz danach meine ganzen Vokabeldateien + Tutorien exportiert, um eine Weile auf meinem Laptop arbeiten zu können. Ich weiß daher nicht, ob die aktuellen Probleme mit dem Update zusammen hängen oder mit dem Export.

Und zwar ist auf einmal die Sprachausgabe einiger Vokabeldateien - die ich aus dem Vokabeltrainer 3 für Griechisch, Hebräisch und Lateinisch importiert habe - total verstümmelt. Die meisten Wörter haben auf einmal gar keine Sprachausgabe mehr und wenn, dann fehlerhaft. Manche Wörter mit mehreren Spracheinträgen (z.B. wegen grammatischer Besonderheiten) haben dann wieder Sprachausgabe. Die englischen Vokabeldateien, die beim VT4 dabei waren, funktionieren hingegen noch tadellos.
Ich blicke leider überhaupt nicht durch, wo nun das Problem liegt und wie ich es beheben kann. Meine Vermutung ist, dass das Update wohl irgendwas überschrieben hat... Ah ja, auf dem Laptop, wo ich die exportierten Dateien importiert habe, ist es genauso kaputt...
#2 Re: Probleme seit Update/Export von Jörg-Michael Grassau 29.05.2009 20:52

Hallo,

ab Version 4.0.7 werden altgriechische und althebräische Vertonungen im Vokabeltrainer anders verarbeitet - vorher wurden sowohl die Vokabeln als auch die Vertonungslisten in speziellen Zeichensätzen (nämlich BwHeb und BwGrk) gespeichert; jetzt verwenden die Vertonungslisten Unicode, sind also Zeichensatz-unabhängig. Das hat den Vorteil, dass z.B. auch Vokabeldateien, in denen die Zeichensätze SHebrew und SGreek verwendet werden (wie in einigen der Download-Vokabeldateien), auf dieselben Vertonungen zugreifen können.

Wahrscheinlich lässt sich das von Ihnen beschriebene Problem lösen, indem Sie die altsprachlichen Vertonungen einfach noch einmal mit dem aktuellen Update aus Version 3 importieren. Dazu müssten Sie zunächst bitte die bestehenden Media-Sammlungen löschen: Menü "Anwender / Verwendete Dateiordner", Zeile "Öffentliche Dateien", Schaltfläche "Öffnen"; dann im Unterordner "Media" die vier Dateien "Audio_GRC_V3Th_w" und "Audio_HBO_V3Th_w" (jeweils mit der Endung .mi4 und .md4) löschen (mit den lateinischen Vertonungen sollte es eigentlich keine Probleme geben, daher müssen sie nicht gelöscht werden). Anschließend rufen Sie das Menü "Vokabeldatei / Importieren / Vokabeldatei aus Version 3", Registerkarte "Alle Dateien übertragen" auf, stellen oben den Ordner ein, in dem sich die Altsprachen-Version 3 befindet, deaktivieren alle Optionen bis auf die Option "Media-Dateien kopieren" im Abschnitt "Mitgelieferte Daten" - und klicken auf "Übertragung beginnen". Jetzt müssten die Media-Sammlungen neu übertragen (und dabei zu Unicode umgewandelt) werden und danach (hoffentlich) funktionieren.

Ausnahme sind die tildierten Formen (z.B. tildierte Genitiv-Formen im Griechischen) - auf die müssten Sie bis zum Erscheinen der offiziellen Altsprachen-Version 4 wohl leider verzichten.

Viele Grüße
Jörg-Michael Grassau
#3 Re: Probleme seit Update/Export von milano 30.05.2009 09:52

Vielen Dank, daran hat es gelegen.
Xobor Forum Software ©Xobor.de | Forum erstellen
Datenschutz