#1 Update Vokabeltrainer von thobie 11.10.2008 08:55

Beim Update-Versuch (Vista-Rechner) kommt die Fehlermeldung:

"Aufruf fehlgeschlagen. Sie benötigen Schreibzugriff auf C:\ProgramFiles und \ProgramData\...".

Obwohl ich die Ordner freigegeben habe kommt immer dieselbe Fehlermeldung.

Was genau muss ich da tun?
#2 Re: Update Vokabeltrainer von joerg 11.10.2008 10:23

die freigabe in windows system- oder programmordnern
funktioniert nach meiner erfahrung nie.
obwohl angeblich die freigabe eingerichtet ist
und auch angezeigt wird, kann man übers netz nicht
draufzugreifen.

am besten die datei: Redirect.txt benutzen
(ins verzeichns legen, wo auch die Vokabeltrainer.exe liegt)
und die verzeichnisse auf einer anderen Partition benutzen.

ALLUSER_PATH=\\rechnername\vokabeltrainer\eigene_daten\Alle\
PRIVATE_PATH=\\rechnername\vokabeltrainer\eigene_daten\Anwender\

joerg
#3 Re: Update Vokabeltrainer von vonni 11.10.2008 10:48

avatar
thobie> "Aufruf fehlgeschlagen. Sie benötigen Schreibzugriff auf C:\ProgramFiles und \ProgramData\...".

Hallo thobie,
bei Vista Home muß man aufpassen. Da werden manche Verzeichnisse einfach intern umgemappt.

Leider haben damit dann die Programme manchmal Probleme, so dass es mittlerweile fast besser ist die Anwendungen unter Vista nicht in C:\Programme zu legen (zumindest, wenn man den Problemen aus dem Weg gehen möchte).

Schau mal, hier hat jemand mit der Firefox-Installation ein ganz ähnliches Problem. Vielleicht hilft Dir das weite:
http://www.computerbase.de/forum/showthread.php?p=4761983


Ich weiß schon, wieso ich mich bislang wehement weigere Vista zu installieren und lieber bei meinem guten alten XP bleibe...
#4 Re: Update Vokabeltrainer von thobie 11.10.2008 11:59

Also: WinVista will und kann ich nicht verteufeln, es ist viel besser als sein Ruf.

Es muss andere Möglichkeiten geben; ich hoffe der Herr Grassau weiß mehr.

Eigentlich bin ich schon ein wenig verärgert, dass ich mich als Programmkäufer um diese Einstellungen kümmern muss. Ich dachte, das Programm wäre für Vista geeignet.

Hat da jemand seine Programmieraufgaben nicht ganz erfüllt?
#5 Re[2]: Update Vokabeltrainer von Jörg-Michael Grassau 11.10.2008 12:39

Hallo thobie,

welche Programmversion verwenden Sie (siehe das Menü "? / Info zum Vokabeltrainer")? Ab Version 3.0.12 (und natürlich ab Version 4.0.0) wird das Update nicht mehr nach c:\Programme gespeichert, sondern in den Ordner mit "Anwendungsdaten", auf den Sie eigentlich auch unter Vista Schreibzugriff haben. Diese Fehlermeldung sollte ab Version 3.0.12 also nicht mehr auftreten.

Falls Sie dagegen eine ältere Version (vor 3.0.12) installiert haben, kann dieser Fehler unter Vista aber auftreten - in diesem Falle würde ich Ihnen empfehlen, das Update für Version 3 direkt von vokabeln.de zu laden und zu starten; alle folgenden Updates sollten dann vom Programm aus funktionieren.

Viele Grüße
Jörg-Michael Grassau
#6 Re[2]: Update Vokabeltrainer von Alvos 11.10.2008 13:03

thobie>Also: WinVista will und kann ich nicht verteufeln, es ist viel besser als sein Ruf.

thobie>Es muss andere Möglichkeiten geben; ich hoffe der Herr Grassau weiß mehr.

thobie>Eigentlich bin ich schon ein wenig verärgert, dass ich mich als Programmkäufer um diese Einstellungen kümmern muss. Ich dachte, das Programm wäre für Vista geeignet.

thobie>Hat da jemand seine Programmieraufgaben nicht ganz erfüllt?

Naja, ich habe auch Vista auf einem Notebook drauf, bin schon ein paar Tage in diesem Forum unterwegs und weiß daher beiderseitig, wovon ich rede. Wenn ich entscheiden sollte, wer mehr um das Wohl seiner User bedacht ist, Vista oder Herr Grassau, wüsste ich ziemlich genau, für wen ich mich entscheiden würde.

Es geschieht nicht nur beim Vokabeltrainer, sondern auch bei anderen und sogar Microsoft Anwendungen, dass diese Meldung vorkommt.
#7 Re: Update Vokabeltrainer von Paradoxx 13.10.2008 12:24

mit der Version 3 ging es auch einwandfrei. nun hab ich mir Version 4 zugelegt und der Fehler ist wieder da!
#8 Re: Update Vokabeltrainer von thobie 13.10.2008 14:02

Da ich dies genau hier schreibe, verwende ich Vokabeltrainer Version 4.0. Meine Vista-Version ist Home Premium (aber wohl egal).

Ich habe das Update 4.0.5 mittlerweile nach Download der msi-Datei und dem Ausführen derselben installiert bekommen. Die o.g. Probleme treten bei einem Updateversuch über die Programmmenüleiste "Online ... etc." (oder so ähnlich) auf.
#9 Re[2]: Update Vokabeltrainer von Jörg-Michael Grassau 15.11.2008 00:08

Hallo,

das aktuelle Update 4.0.6 müssten Sie, falls es über "Onlines / Update suchen und installieren" nicht klappt, bitte noch einmal von der Update-Seite auf vokabeln.de installieren. Spätestens danach (d.h. ab der Installation des nächsten Updates 4.0.7) müsste es dann über den Menüweg funktionieren!

Viele Grüße
Jörg-Michael Grassau
Xobor Forum Software ©Xobor.de | Forum erstellen
Datenschutz