#1 Vokabeltrainer kann seine eigenen Exporte nicht korrekt importieren. von Alvos 01.09.2007 19:46

Moin,

da ich in Excel eine ganze Menge französische Konjugationen in mehreren Zeiten gespeichert habe, die auf anderem Wege nur schlecht im freien Zugriff zu üben sind, wollte ich diese in den Vokabeltrainer übernehmen. Ich habe mir nach dem Muster in der Hilfe einige Vokabeln jeweils in einem 2x3 Feld angelegt. Das Ganze ist zwar nicht vertont und bedurfte anfangs den ständigen Griff nach mit Lautschrift versehenen Tabellen. Dennoch hat sich das Abfragen mittels Ausblenden einer Form oder mit der Orientierung am Infinitiv als sehr effektive Lernmethode bewiesen. Jetzt muss ich nicht mehr die sechs Formen sequentiell runterbeten, bis ich an der richtigen angekommen bin, sondern kann ziemlich sicher wahlfrei darauf zugreifen. Auch umgekehrt hat sich das schnelle reflexartige Erkennen von Formen in einem französischen Text stark verbessert. Zuvor war jedesmal ein Stocken im Text mit bewusstem Dekodieren erforderlich.

Leider ist die direkte Eingabe der vielen unregelmässigen Formen in mehreren Zeiten in den Vokabeltrainer trotz Verfielfältigung eines Mustereintrages recht mühsam. Daher sann ich auf eine Methode den ganzen Schwung auf einmal aus Excel zu übernehmen. Dazu mussten die Einträge innerhalb von Excel in eine Form gebracht werden, die in eine Textdatei kopiert, von dort wieder in den VT einlesbar ist. Mit normalen Vokabeln geht das ganz easy. Zwei Spalten aus Excel mit Copy und Paste in die Textdatei kopieren und von dort mit der Importfunktion in den VT und voila.

Da dies funktioniert, bräuchte man in Excel die Formen nur durch einmal ausgeklügelte Textverkettungungsfunktionen in je eine französische und eine deutsche Spalte zu quetschen. Und zwar nach demselben Prinzip, wie die Zeichen in der kleinen Spalte des Eingabebildschirms des VT angeordnet sind und dabei die Formen einfügen. Statt des Rechtspfeils nimmt man "(Leerzeichen)-(Leerzeichen)". So macht es jedenfalls scheinbar der VT, wenn ich die schon von Hand eingegeben Vokabeln herausexportiere und mir im Windows Editor betrachte. Aber wie ich die Sache auch drehte und wendete: Es funktionierte nicht. Im Vokabeltrainer gab es nach jedem Import einen Buchstabensalat aber keine richtige Zuordnung in die vorgesehenen Boxen. Lediglich die Trennung französisch-deutsch an dem von Excel zwischen den zwei Spalten eingefügten Tab und die Trennung der verschiedenen Datensätze voneinander durch den Zeilenvorschub (heißt das so?) funktionierte richtig.

Bis ich auf der Suche nach der Ursache auf die glorreiche Idee kam, die vom Vokabeltrainer exportierten Dateien in eine hierzu frisch erzeugte andere Vokabeldatei zurückzuschreiben. Und das ergab den exakt gleichen Buchstabensalat. Entweder in der Export- oder wahrscheinlicher in der Importfunktion könnte sich ein Fehler befinden.

Nun ergeben sich folgende Fragen:
1) Ist meine Vorgehensweise bei der Übertragung von Excel nach VT richtig?
2) Oder handelt es sich um einen Bug?
3) Könnte dieser gegebenenfalls behoben werden?

Wenn ich diese Sache ans Laufen bekommen habe, werde ich die Textverkettungsfunktion hier posten, damit sich in Zukunft jeder solche 2x3 Formen kopieren kann. Das wäre dann vielleicht auch ein Ding für die Hilfedatei des VT.

Über eine Antwort würde ich mich freuen
Grüße Alvos
#2 Re: Vokabeltrainer kann seine eigenen Exporte nicht korrekt importieren. von Jörg-Michael Grassau 04.09.2007 09:23

Hallo Alvos,

danke für Ihren ausführlichen Beitrag! Dazu folgende Vorbemerkung: Grundsätzlich kann das Format, in dem die Vokabeleinträge im Vokabeltrainer gespeichert werden, beim Export in eine Textdatei bzw. Import aus einer Textdatei nicht vollständig "abgebildet" werden - dazu ist es einfach zu komplex. Im Vokabeltrainer können Sie z.B. in einem Satz mehrere "Lücken" erstellen, zu diesen Lücken jeweils mehrere Zusatzinformationen vom Typ "Richtige Alternative" eingeben und jede Zusatzinformation ihrerseits mit mehreren Media-Dateiverweisen und Lautschrift verknüpfen. Wenn man das in eine Textdatei exportieren wollte, käme eine komplizierte Verschachtelung heraus, die kaum noch eine Weiterverarbeitung ermöglichen würde (bzw. umgekehrt beim Import zu fehleranfällig wäre).

Daher muss das "Textformat" zwangsläufig eingeschränkt sein und kann nur die wichtigsten Fälle berücksichtigen (und auch die sind schon ziemlich komplex, siehe Hilfetext). Das Deklarieren einer Eingabezeile als "Form" gehört bislang nicht zu den berücksichtigten Fällen, d.h. auch wenn Sie solche "Formen" exportieren, werden sie beim Reimport als normale Eingabezeilen ("Wort 1", "Wort 2" etc.) eingelesen. Die Grundidee der Exportfunktion ist auch nicht, Textdateien herzustellen, die später wieder eingelesen werden sollen, sondern eher, Vokabeleinträge zu exportieren, die dann anders weiterbearbeitet werden sollen (z.B. um sie in einen Text in Word einzufügen etc.).

Das Importieren von "Formen" ist also nicht möglich - wenn Sie allerdings schreiben

Alvos>Im Vokabeltrainer gab es nach jedem Import einen Buchstabensalat

dann klingt das dennoch nach einem Fehler, der aber wahrscheinlich damit zusammenhängt, dass die Textdatei mit der falschen Codierung eingelesen wird. Bitte überprüfen Sie einmal, was in der Registerkarte "Einstellungen" als "Codierung der Textdatei" eingestellt ist, und ob das der Einstellung entspricht, mit der die Textdatei gespeichert wurde. Am wenigsten Fehleranfällig ist es, immer Unicode zu verwenden (also z.B. im Programm Editor "Datei / Speichern unter" aufzurufen und unten als Codierung "Unicode" einzustellen).

Viele Grüße
Jörg-Michael Grassau
#3 Re[2]: Vokabeltrainer kann seine eigenen Exporte nicht korrekt importieren. von Alvos 06.09.2007 08:18

Vielen Dank Herr Grassau für die Hinweise.

Jörg-Michael Grassau:
>Die Grundidee der Exportfunktion ist auch nicht, Textdateien herzustellen, die später wieder eingelesen werden sollen, sondern eher, Vokabeleinträge zu exportieren, die dann anders weiterbearbeitet werden sollen (z.B. um sie in einen Text in Word einzufügen etc.).


Sie haben sicher recht, dass das nicht der Sinn des Exports ist. Ich habe ihn lediglich als Hilfsfunktion angesehen, um damit festzustellen, wie ich die Excel Dateien in Text übersetzen muss, damit dieser dann über die Import Funktion vom Vokabeltrainer korrekt eingelesen werden kann. Es ist ja die einzige Möglichkeit, dahinter zu bekommen. Ich hatte vermutet, dass der Trainer beim Export dasselbe Format produziert, das er auch zum Import benötigt.

Leider wüßte ich auch nach Ihren Hinweisen nicht, was ich falsch gemacht haben könnte. Daher habe ich die Vokabeldatei radikal vereinfacht. Zudem habe ich diesmal keine "Form"en, sondern "Wort"e sowie nur zwei kurze Vokabeleinträge eingetragen, wobei der zweite vom ersten kopiert und damit absolut identisch ist.

Der ganze Vorgang ist jetzt durch Bildschirmfotos nachvollziehbar. Ich habe versucht, diese im Forum hochzuladen, aber beim Klick auf Hochladen wird das Fenster mit dem Namen der Upload Datei immer wieder geleert und nach deren Namen gefragt. Daher habe ich die Bilder extern hochgeladen. Die Bilder können nach dem Vergrößern auf Bildschirmgröße durch Rechtsklick auch lokal gespeichert werden. Hier ist der Link zum Fotoalbum:

http://www.arcor.de/palb/einladung_accept.jsp?key=IJHVH84CZDOozuDv5Pd1Rtea%2F7%2BeVmsF96STI5BOq%2BnhNc5WFOVrwg%3D%3D

Die Bildschirmbilder sind in der Reihenfolge des Ablaufs durchnummeriert:

1) Bild eines zu exportierenden Eintrages im Vokabeleditor. Der zweite Eintrag ist kopiert und identisch.
2) Bild des ersten Einstellungsfensters zum Exportieren
3) Bild des zweiten Einstellungsfensters zum Exportieren
4) Bild der erzeugten Textdatei
5) Bild des ersten Einstellungsfensters zum Importieren
6) Bild des zweiten Einstellungsfensters zum Importieren
7) Bild eines importierenden Eintrages im Vokabeleditor. Der zweite Eintrag ist identisch.

Übrigens, das Einstellen des "Unicode" Fensters wird von den Standardeinstellungs Klick beim Import nicht richtig beeinflusst. Zudem ist beim erneuten Aufrufen einer Datei der "Unicode" Eintrag beim Import wieder verschwunden.

Vielleicht ist es Ihnen möglich, anhand der Bilder den Fehler zu lokalisieren. Über eine Antwort würde ich mich freuen

Grüße
Alvos
#4 Re[3]: Vokabeltrainer kann seine eigenen Exporte nicht korrekt importieren. von Jörg-Michael Grassau 11.09.2007 12:25

Hallo,

danke für die genaue Dokumentation des Problems! Wenn ich richtig sehe, verwirrt vor allem das Absatzmarken-Zeichen nach "être". Dieses Zeichen sorgt innerhalb des Vokabeltrainers dafür, dass das Folgende (also die Verbformen) in der nächsten Zeile dargestellt wird. So gesehen könnte der Vokabeltrainer beim Textexport (statt des Absatzmarken-Zeichens) natürlich auch in der Textdatei die nächste Zeile eröffnen:

être
- je suis - nous sommes = sein

Das würde bei einem Reimport allerdings noch mehr Probleme hervorrufen als das Absatzmarken-Zeichen; denn beim Textimport wird der Zeilenvorschub ja meistens verwendet, um das Ende eines Vokabeleintrags und den Beginn des nächsten Eintrags zu signalisieren. So würden beim Textimport dann zwei Vokabeleinträge entstehen:

1. être = [deutsche Übersetzung fehlt]

2. - je suis - nous sommes = sein

Das wäre natürlich ganz falsch. Wie man es also dreht oder wendet - das Format der Vokabeleinträge lässt sich einfach nicht verlustfrei in einer Textdatei abbilden , es sei denn, Sie geben ausschließlich ganz einfach aufgebaute Vokabeleinträge vom Typ "house = Haus" ein.

Viele Grüße
Jörg-Michael Grassau
#5 Re[4]: Vokabeltrainer kann seine eigenen Exporte nicht korrekt importieren. von Alvos 16.09.2007 10:08

Vielen Dank für die Antwort, Herr Grassau.

Ich habe jetzt mal einige Tage ins Land gehen lassen, um dahinter zu kommen, was mir Ihre Antwort sagen will. Aber entweder verstehe ich sie nicht oder wir reden aneinander vorbei. Das ist auf keinen Fall böse gemeint. Vielleicht habe ich das ursprüngliche Problem nicht deutlich genug herausgearbeitet. Lassen wir daher Excel mal außen vor, denn alles damit zusammenhängende kann ich selbst erledigen. Das vereinfacht die Aufgabenstellung, die dann so lautet:

Erstelle eine Textdatei, die beim Import in den Vokabeltrainer auf der linken französischen Seite einen korrekt formatierten Worteintrag bestehend aus zwei Worten erzeugt.

Und da verwirrt mich jetzt dieser Teil Ihrer Antwort:

Jörg Michael Grassau:
das Format der Vokabeleinträge lässt sich einfach nicht verlustfrei in einer Textdatei abbilden,

Denn das ist doch gar nicht das Ziel. Die Expirimente mit dem Export waren ja nur ein Hilfsmittel auf dem Weg und müssen nicht zwingend funktionieren. Vielmehr geht es um die umgekehrte Richtung, nämlich eine Textdatei so hinzubiegen, daß sie einen korrekt formatierten Worteintrag erzeugt. Wenn Sie mir jetzt sagen, dass diese umgekehrte Richtung auch in keinster Weise möglich ist, es keine Steuerzeichen beispielsweise der Art [x],[/x] gibt, die einen von ihnen geklammerten Text in die kleine linke Spalte vor dem Wort fließen lassen, dann sehe ich klar.

Grüße
Alvos
#6 Re[5]: Vokabeltrainer kann seine eigenen Exporte nicht korrekt importieren. von Jörg-Michael Grassau 18.09.2007 12:51

Hallo,

hm, da haben Sie wohl im ersten Beitrag eine relativ einfache Frage ungewollt mit einem recht komplexen Beispiel illustriert, und ich habe eher auf das komplexe Beispiel als auf die einfache Frage geantwortet ... Also:

Alvos>Erstelle eine Textdatei, die beim Import in den Vokabeltrainer auf der linken französischen Seite einen korrekt formatierten Worteintrag bestehend aus zwei Worten erzeugt.

Um das zu erreichen, müssen die beiden Wörter mit einem der folgenden Zeichen voneinander getrennt sein:

* Komma, gefolgt von einem Leerzeichen
* Semikolon, gefolgt von einem Leerzeichen
* Leerzeichen Schrägstrich Leerzeichen

Beispiel: Der Eintrag

setzen, stellen; legen

wird importiert als

Wort 1: setzen
Wort 2: , stellen
Wort 3: ; legen

Anderes Beispiel: Der Eintrag

er / sie / es

wird importiert als

Wort 1: er
Wort 2: / sie
Wort 3: / es

Einschränkung: Die Trennung an diesen drei Trennzeichen wird beim Import nur durchgeführt, wenn

1. in der Registerkarte "Einstellungen" die Option "Stichwörter sind durch Kommata und Semikola getrennt" aktiviert ist,
2. wenn das jeweilige Trennzeichen sich nicht in einer Klammer befindet (z.B. würde der Eintrag "(er / sie / es) geht" nicht an den Schrägstrichen geteilt werden, sondern komplett als "Wort 1" importiert werden) und
3. wenn am Ende des jeweiligen Wortblocks kein Satzzeichen steht (z.B. würde der Eintrag "Hallo, wie geht's?" nicht am Komma getrennt werden, sondern komplett als "Wort 1" importiert werden).

Normale Vokabeln lassen sich damit in der Regel bestens verarbeiten. Was die Sache kompliziert gemacht hat, ist, dass Sie nach Formen und Konjugationen gefragt hatten - die lassen sich per Textimport nicht einlesen. Anders gesagt: Es gibt keine Zeichenfolge, mit der man einen Text importieren könnte, der zu folgendem Vokabeleintrag führen würde:

Wort 1: to go
Form 2: >> went
Form 3: >> gone

Alvos>Steuerzeichen beispielsweise der Art [x],[/x]

Nein, solche Steuerzeichen, mit denen sich Trennzeichen allgemein kennzeichnen lassen, gibt es nicht.

Ich hoffe, jetzt weniger an Ihnen vorbeigeredet zu haben ...

Viele Grüße
Jörg-Michael Grassau
#7 Re[6]: Vokabeltrainer kann seine eigenen Exporte nicht korrekt importieren. von Alvos 18.09.2007 15:10

Ahja, vielen Dank, jetzt sehe ich klar. Übrigens, die Trennung der einzelnen Worte durch Komma + Leerzeichen funktioniert sogar, ohne an der Standardeinstellung des Vokabeltrainers zu basteln. Daher werde ich mich bei der Übergabe von Excel an den Vokabeltrainer auf diese Methode beschränken. Denn der Rest, nämlich die Umwandlung der Worte in Formen sowie die Eingaben in die linke Spalte vor dem Wort-/Formeneintrag ist bei jedem Vokabeleintrag eine feste Abfolge von Tastaturbetätigungen und Mausklicks. Und so etwas dürfte sich mit einem Tastatur-/Mausmakro erledigen lassen.

Das hat allerdings wahrscheinlich den Nachteil, dass ich der Community kein Rezept für solche Formenimporte aufgeben kann, da das Tastatur-/Mausmakro nur bei gleichen Anordnungen und Einstellungen funktioniert. Und da sind die individuellen Möglichkeiten wahrscheinlich unübersehbar, so dass man hier auch nicht angenähert alle möglichen Fälle in einem Rezept berücksichtigen kann.

Inzwischen habe ich den Langenscheidt Grammatiktrainer gefunden. Falls dieser ein Konjugationstraining ohne explizites Eintippen (im Französischen ist das wegen der Akzents der Rechtschreibhorror), also Superlearning ähnlich (möglicherweise sogar vertont) anbietet, könnte ich mir den ganzen Aufwand hier schenken.

Grüße
Alvos
Xobor Forum Software ©Xobor.de | Forum erstellen
Datenschutz